Command Center Performance

Incident Report for m3

Identified

We have identified the cause of the Command Center performance issues and are actively working to implement corrective measures. Customers may continue to experience intermittent slowness while remediation efforts are underway. We will provide additional updates as progress is made toward full service restoration.
Posted Aug 25, 2026 - 15:55 UTC

Investigating

We are investigating an issue affecting Command Center login. Some customers may experience slower-than-normal login times when accessing the service. Our team is actively working to identify the cause and restore normal performance. We will provide an update as more information becomes available.
Posted Aug 25, 2026 - 14:06 UTC
This incident affects: Web Portal (East US2).